VCSA CLI install error: format requires a mapping

While writing a standard vCenter installation procedure for a customer, I was testing the CLI installation of the Platform Service Controller (PSC) for VMware vCenter 6.5.

I really love the CLI installation method, it enables you to perform the same install procedure over and over again. If you want to know how to create a CLI install for the VCSA, I wrote a blog post about this topic a while ago.

 

While testing the procedure, I got the following error:

================= [7] Service Installation started at 09:49:02 =================
Installing services...
Service Installation: Progress: 5% Setting up storage
Service Installation: Progress: 60% Installed
VMware-unixODBC-2.3.2.vmw.2-6.5.0.x86_64.rpm
Service Installation: Progress: 64% Installed
vmware-directory-client-6.5.0.1691-5776897.x86_64.rpm
Service Installation: Progress: 80% Installed
VMware-cis-license-6.5.0-5694622.x86_64.rpm
Service Installation: Progress: 95% Configuring the machine
vCenter Server Service installations succeeded.
============ [8] vCenter Service Configuration started at 09:58:30 ============
Configuring services for first time use...
format requires a mapping
Traceback (most recent call last):
File "D:/build/toolchain\win32\cx-Freeze-4.3.4-python2.7.11-openssl-1.0.2j-vc90sp1\python2.7\Lib\site-packages\cx_Freeze\initscripts\Conso
le.py", line 27, in 
File "main.py", line 1023, in 
TypeError: format requires a mapping

A quick Google search didn’t helped me alot, so I started troubleshooting for my own.

While performing a second installation, I was monitoring when the error occurs.

The OVF is deployed successfully and the Photon OS is configured with the configured network settings. As you can see in the error output, the error occurs when de installation want to configure (remotely) the services. When it tried to ping the VM, I didn’t got a reply back, so the problem had to be network related.

After some more troubleshooting, I noticed that the default gateway wasn’t correctly and the management VM from which I performed the installation, was in a different subnet. Although it was the default gateway IP I got from the customer, the customer made a mistake in the IP address. 

To resume: The error: “format requires a mapping” indicates, that the CLI installer cannot connect to the VCSA VM over the network.

When the correct default gateway was configured, the installation passed.

About Michael
Michael Wilmsen is a VMware training/consultant (no specific order) with more than 15 years in the IT industry. Main focus is VMware vSphere, Horizon View and Site Recovery Manager with a deepdive to performance. Michael is VCDX 210, VCAP 4/5 certified, has been rewarded with the vExpert title from 2011, is a PernixPro, Nutanix Tech Champion and a Nutanix Platform Professional.

RSS feed for comments on this post. TrackBack URI

Leave a Reply

You must be logged in to post a comment.